March 1st update.

about a month ago by danmcd
Page History
  1. OmniOS r151020 
  2. March 1 2017 Update 
  3. December 31 2016 Update 
  4. r151020 release 
  5. What's NOT new in this release? 
  6. What is new in this release? 
  7. Package changes ([+] Added, [-] Removed, [*] Changed) 

OmniOS r151020 #

March 1 2017 Update #

illumos-omnios branch r151020 at 4151d05

uname -v/uname -a shows omnios-r151020-4151d05

  • Restored includes-branch uname format.
  • HP Gen9 sudden-reboot fix with the Broadcom NIC (bge).
  • i40e now uses multiple receive and transmit rings, for better per-flow performance.
  • Small bugfixes in NFS, ZFS, NVMe, and LSI HBA support (mpt_sas).

December 31 2016 Update #

illumos-omnios branch r151020 at bed3013

uname -a shows omnios-bed3013

  • Chelsio Terminator T5 NIC support
  • Security and reliability updates to procfs and tmpfs

r151020 release #

Stable Release, November 4, 2016

illumos-omnios branch r151020 at b5b8c75

uname -a shows omnios-r151020-b5b8c75

  • Last full illumos-gate merge was b6bc2fd. Because of high upstream churn, this is earlier than most OmniOS stable releases. Several cherrypicks of device support occurred after the freeze.

r151020 release repository: http://pkg.omniti.com/omnios/r151020/

Please read the upgrade instructions carefully. The end-of-life for SunSSH means SunSSH-deployments must change over to OpenSSH.

What's NOT new in this release? #

NOTE: The BSD Loader, ASLR, and Python2.7-for-illumos are NOT included in this release. The sample .env files shipped in the illumos-tools package, used for building illumos-omnios, reflect this by setting the PYTHON_VERSION environment variable to 2.6. This allows one to build both future illumos-omnios and current illumos-gate on r151020.

It is currently planned that during the next Bloody cycle (r151021) and its following LTS release (r151022) these major features and changes will be matured and integrated into OmniOS.

What is new in this release? #

  • SunSSH has reached its End-of-Life and is no longer included in OmniOS, having been fully replaced by OpenSSH. Important: it is preferred that an upgrade to OpenSSH is done prior to installing OmniOS r151020. See the upgrade instructions for how to successfully transition if you have not already abandoned SunSSH.
  • Introduction of the omnios/library/nghttp library package, allowing HTTP/2 support in the shipped curl(1) and libcurl(3)
  • VIM is now at version 8.0. The default for vi was always vim. With version 8.0, this is now more noticeable.
  • All driver improvements already in r151018 updates.
  • Timezone database update to version 2016h.
  • Several small NVMe fixes, culminating in introductory NVMe 1.1 support.
  • Intel I219 ("Kaby Lake") gigabit ethernet chip support in the e1000g driver.
  • ACPI Version 6 support.
  • Public documentation of libproc(3LIB).
  • Initial support for ISO/IEC 9899:2011 (C11) standards.
  • Various man page cleanups.
  • DTrace now supports "if" and "else" statements.
  • ZFS L2ARC now caches compressed data.
  • Many small/medium-sized ZFS improvements.

Package changes ([+] Added, [-] Removed, [*] Changed) #

  • bash 4.3 -> 4.4 [*]
  • bind 9.10.4-P2 -> 9.10.4-P4 [*]
  • ca-bundle See Mozilla NSS/NSPR
  • curl 7.48 -> 7.51.0 [*]
  • dbus-glib 0.106 -> 0.108 [*]
  • dbus 1.10.8 -> 1.11.4 [*]
  • diffutils 3.3 -> 3.5 [*]
  • expat 2.1.1 -> 2.2.0 [*]
  • fio 1.2 [+]
  • gawk 4.1.3 -> 4.1.4 [*]
  • gettext 0.19.7 -> 0.19.8.1 [*]
  • git 2.8.0 -> 2.10.0 [*]
  • gnu-make 4.1 -> 4.2.1 [*]
  • gnump 6.1.0 -> 6.1.1 [*]
  • grep 2.24 -> 2.26 [*]
  • gtar 1.28 -> 1.29 [*]
  • gzip 1.6 -> 1.8 [*]
  • iperf 3.1.2 -> 3.1.3 [*]
  • isc-dhcp 4.3.3-P1 -> 4.3.5 [*]
  • iso-codes 3.66 -> 3.70 [*]
  • libidn 1.32 -> 1.33 [*]
  • libxslt 1.1.28 -> 1.1.29 [*]
  • mercurial 3.7.3 -> 3.9.2 [*]
  • Mozilla NSS/NSPR 3.25/4.12 -> 3.26/4.12 [*]
  • nghttp2 1.15.0 [+]
  • p7zip 9.20.1 -> 16.02 [*]
  • pciutils 3.4.1 -> 3.5.2 [*]
  • pcre 8.38 -> 8.39 [*]
  • python26-coverage 4.0.3 -> 4.2 [*]
  • python26-lxml 3.6.0 -> 3.6.4 [*]
  • python26-numpy 1.11.0 -> 1.11.2 [*]
  • python26-ply 3.8 -> 3.9 [*]
  • python26-pylint 1.5.5 -> 1.6.4 [*]
  • readline 6.3 -> 7.0 [*]
  • screen 4.3.1 -> 4.4.0 [*]
  • sigcpp 2.8.0 -> 2.10.0 [*]
  • sqlite3 3.12.0 -> 3.15.0 [*]
  • tmux 2.1 -> 2.3 [*]
  • vim 7.4 -> 8.0 [*]